summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit6
2 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 0dc3014..4a0883c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
dgit (5.3~) unstable; urgency=medium
Bugfixes:
+ * dgit: Do not introduce duplicate origs in .changes files,
+ eg if the .changes already has that orig. Closes:#869146.
* Honour GIT_REFLOG_ACTION everywhere. Closes:#901935.
* git-debrebase new-upstream: Provide better reflog entries
by setting GIT_REFLOG_ACTION. Closes:#901925.
diff --git a/dgit b/dgit
index bbfaea1..d18cc73 100755
--- a/dgit
+++ b/dgit
@@ -1975,12 +1975,12 @@ END
if ($found_same) {
# in archive, delete from .changes if it's there
$changed{$file} = "removed" if
- $changes->{$fname} =~ s/^.* \Q$file\E$(?:)\n//m;
- } elsif ($changes->{$fname} =~ m/^.* \Q$file\E$(?:)\n/m) {
+ $changes->{$fname} =~ s/\n.* \Q$file\E$(?:)$//m;
+ } elsif ($changes->{$fname} =~ m/^.* \Q$file\E$(?:)$/m) {
# not in archive, but it's here in the .changes
} else {
my $dsc_data = getfield $dsc, $fname;
- $dsc_data =~ m/^(.* \Q$file\E$)\n/m or die "$dsc_data $file ?";
+ $dsc_data =~ m/^(.* \Q$file\E$)$/m or die "$dsc_data $file ?";
my $extra = $1;
$extra =~ s/ \d+ /$&$placementinfo /
or die "$fname $extra >$dsc_data< ?"