summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit7
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 29a7c26..d99f3bc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,9 @@ dgit (0.21~~iwj) unstable; urgency=low
Closes:#731632.
* Be able to clone or fetch from Debian backports suites (which are
a bit like main Debian suites but also a bit not like them).
+ * Compute "-v" option default value (changelog version since) correctly
+ for Debian backports suites.
+ * Closes:#733954.
--
diff --git a/dgit b/dgit
index a5736e1..94b9ab1 100755
--- a/dgit
+++ b/dgit
@@ -1857,6 +1857,13 @@ sub changesopts () {
my @opts =@changesopts[1..$#changesopts];
if (!defined $changes_since_version) {
my @vsns = archive_query('archive_query');
+ my @quirk = access_quirk();
+ if ($quirk[0] eq 'backports') {
+ local $isuite = $quirk[2];
+ local $csuite;
+ canonicalise_suite();
+ push @vsns, archive_query('archive_query');
+ }
if (@vsns) {
@vsns = map { $_->[0] } @vsns;
@vsns = sort { -version_compare_string($a, $b) } @vsns;