summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit5
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 1d912c0..784269c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ dgit (3.12~) unstable; urgency=medium
* Defend against commit subject lines which would generate patches which
look like series files, etc. Involves adding .patch to all generated
patch filenames.
+ * dgit import: Defend against broken symlinks in ..
--
diff --git a/dgit b/dgit
index 5197596..a68bf19 100755
--- a/dgit
+++ b/dgit
@@ -6349,7 +6349,10 @@ END
foreach my $fi (@dfi) {
my $f = $fi->{Filename};
my $here = "../$f";
- next if lstat $here;
+ if (lstat $here) {
+ next if stat $here;
+ fail "lstat $here works but stat gives $! !";
+ }
fail "stat $here: $!" unless $! == ENOENT;
my $there = $dscfn;
if ($dscfn =~ m#^(?:\./+)?\.\./+#) {