summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xinfra/dgit-repos-server4
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index c73480b..b1c7db1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,10 @@ dgit (3.6~) unstable; urgency=medium
Infrastructure:
* Properly honour NOCOMMITCHECK policy hook exit status.
Closes:#851800.
+ * Do not reject commits with no author/committer name (but still insist
+ on email address and date). Peter Green reports that eg
+ 71e128629ec786f3 in upstream xen.git is such a commit (and is accepted
+ by github). Closes:#851716.
Test suite:
* downstream-gitless: Test import of .dsc from unknown distro.
diff --git a/infra/dgit-repos-server b/infra/dgit-repos-server
index aa6fecd..6131774 100755
--- a/infra/dgit-repos-server
+++ b/infra/dgit-repos-server
@@ -897,8 +897,8 @@ sub checks () {
# defend against commits generated by #849041
if (!($policy & NOCOMMITCHECK)) {
- my @checks = qw(%an %ae %at
- %cn %ce %ct);
+ my @checks = qw(%ae %at
+ %ce %ct);
my @chk = qw(git log -z);
push @chk, '--pretty=tformat:%H%n'.
(join "", map { $_, '%n' } @checks);