summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit9
2 files changed, 5 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 910c34d..84cf7de 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ dgit (0.9) unstable; urgency=low
* In push, double-check the .changes against the changelog.
* Better error when source package contains .git. Closes: #720555.
* Change our .dsc field name to `Dgit'. Relevant to #720201.
+ * Fix bug handling our synthetic merges when we see them in
+ the remote suite branch.
--
diff --git a/dgit b/dgit
index 88f018d..c0c7b8d 100755
--- a/dgit
+++ b/dgit
@@ -591,12 +591,9 @@ Last allegedly pushed/uploaded: $oversion (newer or same)
$later_warning_msg
END
$outputhash = $upload_hash;
- } elsif ($outputhash ne $upload_hash) {
- fail "version in archive ($cversion)".
- " is same as version in git".
- " to-be-uploaded (upload/) branch ($oversion)".
- " but archive version hash no commit hash?!";
- }
+ } else {
+ $outputhash = $upload_hash;
+ }
}
chdir '../../../..' or die $!;
runcmd @git, qw(update-ref -m),"dgit fetch import $cversion",