summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit5
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 729985c..686c69c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,6 +15,8 @@ dgit (3.11~) unstable; urgency=medium
core.sharedRepository. Prompted by #867603.
* dgit-badcommit-fixup: Honour core.sharedRepository.
Closes:#867603.
+ * dgit: clone multisuite works even without --no-rm-on-error.
+ Closes:#867434.
* infrastructure: Cope with new git-receive-pack which has
quarantine feature: ie, work around #867702.
* test suite: Cope with git restricting ext:: protocols.
diff --git a/dgit b/dgit
index be277f3..40b8e32 100755
--- a/dgit
+++ b/dgit
@@ -3612,6 +3612,9 @@ END
}
sub clone ($) {
+ # in multisuite, returns twice!
+ # once in parent after first suite fetched,
+ # and then again in child after everything is finished
my ($dstdir) = @_;
badusage "dry run makes no sense with clone" unless act_local();
@@ -3623,7 +3626,7 @@ sub clone ($) {
printdebug "multi clone after fetch merge\n";
clone_set_head();
clone_finish($dstdir);
- exit 0;
+ return;
}
printdebug "clone main body\n";