summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit3
-rw-r--r--dgit.15
3 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 34b9388..d4cdd9d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -51,6 +51,7 @@ dgit (1.1~~) unstable; urgency=low
before the actual header, so dgit works with https_proxy set (!)
* When key to use not specified any other way, use the debian/changelog
trailer line. Closes:#793423.
+ * Honour --git= (mostly).
--
diff --git a/dgit b/dgit
index 270f925..b7c6d9a 100755
--- a/dgit
+++ b/dgit
@@ -91,13 +91,14 @@ our %opts_opt_map = ('dget' => \@dget, # accept for compatibility
'sbuild' => \@sbuild,
'ssh' => \@ssh,
'dgit' => \@dgit,
+ 'git' => \@git,
'dpkg-source' => \@dpkgsource,
'dpkg-buildpackage' => \@dpkgbuildpackage,
'dpkg-genchanges' => \@dpkggenchanges,
'ch' => \@changesopts,
'mergechanges' => \@mergechanges);
-our %opts_opt_cmdonly = ('gpg' => 1);
+our %opts_opt_cmdonly = ('gpg' => 1, 'git' => 1);
our %opts_cfg_insertpos = map {
$_,
scalar @{ $opts_opt_map{$_} }
diff --git a/dgit.1 b/dgit.1
index dcf4408..d73d5b9 100644
--- a/dgit.1
+++ b/dgit.1
@@ -430,6 +430,7 @@ Specifies alternative programs to use instead of
.BR gpg ,
.BR ssh ,
.BR dgit ,
+.BR git ,
or
.BR mergechanges .
@@ -476,6 +477,10 @@ this applies only when the program is invoked directly by dgit.
Usually, for passing options to dpkg-genchanges, you should use
.BR --ch: \fIoption\fR.
+Specifying --git not effective for some lower-level read-only git
+operations performed by dgit, and also not when git is invoked by
+another program run by dgit.
+
See notes above regarding ssh and dgit.
NB that --gpg:option is not supported (because debsign does not