summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit4
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5422a93..a5abed6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -58,6 +58,9 @@ dgit (0.23~) unstable; urgency=low
* Document in manpage under `dgit push' that it is best to build with
dgit too. Closes:#763333.
+ * Fix inaccurate error message when archive's git hash is not an
+ ancestor of git repo's git hash.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index 2e67eb5..a73fffd 100755
--- a/dgit
+++ b/dgit
@@ -1355,8 +1355,8 @@ $later_warning_msg
END
$hash = $lastpush_hash;
} else {
- fail "archive's .dsc refers to ".$dsc_hash.
- " but this is an ancestor of ".$lastpush_hash;
+ fail "git head (".lrref()."=$lastpush_hash) is not a ".
+ "descendant of archive's .dsc hash ($dsc_hash)";
}
} elsif ($dsc) {
$hash = generate_commit_from_dsc();