summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8fa1f15..b0c8811 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (3.1~) unstable; urgency=medium
Bugfixes:
+ * dgit import-dsc: Do not crash with undefined $isuite. Closes:#850781.
* dgit: Do not nedlessly re-fetch the rewrite map.
--
diff --git a/dgit b/dgit
index d3673c2..eee1806 100755
--- a/dgit
+++ b/dgit
@@ -6105,6 +6105,8 @@ Specify +$specbranch to overwrite, discarding existing history
END
if $oldhash && !$force;
+ notpushing();
+
my @dfi = dsc_files_info();
foreach my $fi (@dfi) {
my $f = $fi->{Filename};