summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit5
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 91bb617..cd44b40 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,9 @@ dgit (3.11~) unstable; urgency=medium
tree.
* dgit: tolerate compressor terminating with SIGPIPE.
Closes:#857694.
+ * dgit: honour more pre-tree git config options in our private
+ trees sharing the user's object store. In particular,
+ core.sharedRepository. Prompted by #867603.
* infrastructure: Cope with new git-receive-pack which has
quarantine feature: ie, work around #867702.
* test suite: Cope with git restricting ext:: protocols.
diff --git a/dgit b/dgit
index edb2428..be277f3 100755
--- a/dgit
+++ b/dgit
@@ -1713,7 +1713,10 @@ sub prep_ud (;$) {
sub mktree_in_ud_here () {
runcmd qw(git init -q);
runcmd qw(git config gc.auto 0);
- foreach my $copy (qw(user.email user.name user.useConfigOnly)) {
+ foreach my $copy (qw(user.email user.name user.useConfigOnly
+ core.sharedRepository
+ core.compression core.looseCompression
+ core.bigFileThreshold core.fsyncObjectFiles)) {
my $v = $gitcfgs{local}{$copy};
next unless $v;
runcmd qw(git config), $copy, $_ foreach @$v;