summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 784269c..eeaeb1f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ dgit (3.12~) unstable; urgency=medium
look like series files, etc. Involves adding .patch to all generated
patch filenames.
* dgit import: Defend against broken symlinks in ..
+ * dgit import: Right error message for missing files in ..
--
diff --git a/dgit b/dgit
index a68bf19..944de85 100755
--- a/dgit
+++ b/dgit
@@ -6363,7 +6363,7 @@ END
fail "cannot import $dscfn which seems to be inside working tree!";
}
$there =~ s#/+[^/]+$## or
- fail "cannot import $dscfn which seems to not have a basename";
+ fail "import $dscfn requires ../$f, but it does not exist";
$there .= "/$f";
symlink $there, $here or fail "symlink $there to $here: $!";
progress "made symlink $here -> $there";