summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--tests/lib-core1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 05f08e7..b8809bc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ dgit (3.11~) unstable; urgency=medium
Closes:#867693.
* dgit: Cope if the archive server sends an HTTP redirect,
by passing -L to curl. Closes:#867185,#867309.
+ * test suite: Cope with git restricting ext:: protocols.
--
diff --git a/tests/lib-core b/tests/lib-core
index 6cdffeb..d65a1ff 100644
--- a/tests/lib-core
+++ b/tests/lib-core
@@ -24,6 +24,7 @@ t-set-using-tmp () {
export GNUPGHOME=$tmp/nonexistent
git config --global user.email 'dgit-test@debian.example.net'
git config --global user.name 'dgit test git user'
+ git config --global protocol.ext.allow always
}
t-filter-out-git-hyphen-dir () {