summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit2
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 3be04f0..984e6cb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,10 @@ dgit (1.5~~) unstable; urgency=medium
has been changed recently and now this default setting is very awkward
to change for the dgit user.
+ New checks and improved behaviours:
+ * In dgit sbuild, check that the set of .changes files found is as we
+ expect, before calling mergechanges
+
Bugfixes:
* When cleaning up after failed clone, stat the to-be-cleaned-up
directory before running rmtree on it. Closes:#796773.
diff --git a/dgit b/dgit
index de7ee0c..32eaa2a 100755
--- a/dgit
+++ b/dgit
@@ -3153,7 +3153,7 @@ sub cmd_sbuild {
or $a cmp $b
} @changesfiles;
fail "wrong number of different changes files (@changesfiles)"
- unless @changesfiles;
+ unless @changesfiles==2;
runcmd_ordryrun_local @mergechanges, @changesfiles;
my $multichanges = "${package}_".(stripepoch $version)."_multi.changes";
if (act_local()) {