summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xinfra/dgit-mirror-ssh-wrap2
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8b2d064..2d537c1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
dgit (9.12~) unstable; urgency=medium
- *
+ Bugfixes:
+ * dgit-mirror-ssh-wrap: Cope with yet another new rsync rune.
+ Closes:#968635. [Sergio Durigan Junior]
--
diff --git a/infra/dgit-mirror-ssh-wrap b/infra/dgit-mirror-ssh-wrap
index 7f55fea..afbbbbf 100755
--- a/infra/dgit-mirror-ssh-wrap
+++ b/infra/dgit-mirror-ssh-wrap
@@ -29,6 +29,8 @@ $_ = $command;
m{^rsync --server -lHtre\.iLsfxC --timeout=\d+ --delete --safe-links \. $d$}
||
m{^rsync --server -lHtre\.iLsfxCIv --timeout=\d+ --delete --safe-links \. $d$}
+||
+m{^rsync --server -lHtre\.iLsfxCIvu --timeout=\d+ --delete --safe-links \. $d$}
# To add a new command pattern, add || m{^ ... $} above.
# The pattern should contain $d where the per-package destination