summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control2
-rwxr-xr-xinfra/get-dm-txt6
2 files changed, 4 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index 4251c22..5a9d1cd 100644
--- a/debian/control
+++ b/debian/control
@@ -24,7 +24,7 @@ Description: git interoperability with the Debian archive
dgit clone and dgit fetch construct git commits from uploads.
Package: dgit-infrastructure
-Depends: ${misc:Depends}, perl, git-core, dgit, gpgv, chiark-utils-bin, wget,
+Depends: ${misc:Depends}, perl, git-core, dgit, gpgv, chiark-utils-bin,
libjson-perl, libdigest-sha-perl, libdbd-sqlite3-perl, sqlite3
Architecture: all
Priority: extra
diff --git a/infra/get-dm-txt b/infra/get-dm-txt
index 3c3a62c..9885f9e 100755
--- a/infra/get-dm-txt
+++ b/infra/get-dm-txt
@@ -8,11 +8,11 @@ server=ftp-master.debian.org
path=$file
cert=/etc/ssl/certs/$server.pem
-certargs="--ca-certificate=$cert --ca-directory=/dev/enoent"
+certargs="--cacert=$cert --capath=/dev/enoent"
with-lock-ex -f $file.lock sh -c "
- if ! wget $certargs \
- -O $file.new https://$server/$path >$file.stderr 2>&1; then
+ if ! curl $certargs \
+ >$file.new https://$server/$path 2>$file.stderr; then
cat $file.stderr >&2
exit 127
fi