summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 66aa5e9..4c73fea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ dgit (3.5~) unstable; urgency=medium
Bugfixes:
* Improve comment left in .git/info/attributes.
+ * Defuse gitattributes in private working area even if we don't do it in
+ the user's tree because config setup-gitattributes=false.
--
diff --git a/dgit b/dgit
index 3ff58a7..dae194c 100755
--- a/dgit
+++ b/dgit
@@ -1699,7 +1699,7 @@ sub mktree_in_ud_here () {
runcmd qw(git config gc.auto 0);
rmtree('.git/objects');
symlink '../../../../objects','.git/objects' or die $!;
- setup_gitattrs();
+ setup_gitattrs(1);
}
sub git_write_tree () {