summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit3
-rw-r--r--dgit.118
3 files changed, 23 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4c354a4..24f2ea6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ dgit (2.9~) unstable; urgency=low
* dgit clone: Set timestamps in cloned tree to a single unified time.
This makes it less likely that the user will trip over any
timestamp-dependent FTBFS bugs (eg #842452).
+ * Support dgit --delayed= push (with a warning in the manpage
+ about possible skew).
--
diff --git a/dgit b/dgit
index efd8963..5f923aa 100755
--- a/dgit
+++ b/dgit
@@ -5603,6 +5603,9 @@ sub parseopts () {
} elsif (m/^--overwrite=(.+)$/s) {
push @ropts, $_;
$overwrite_version = $1;
+ } elsif (m/^--delayed=(\d+)$/s) {
+ push @ropts, $_;
+ push @dput, $_;
} elsif (m/^--dgit-view-save=(.+)$/s) {
push @ropts, $_;
$split_brain_save = $1;
diff --git a/dgit.1 b/dgit.1
index 93183cf..4ec02a7 100644
--- a/dgit.1
+++ b/dgit.1
@@ -429,6 +429,24 @@ git history, so that your push is a fast forward from the archive.
implying a split between the dgit view and the
maintainer view, the pseudo-merge will appear only in the dgit view.)
.TP
+.BR --delayed =\fIdays\fR
+Upload to a DELAYED queue.
+
+.B WARNING:
+If the maintainer responds by cancelling
+your upload from the queue,
+and does not make an upload of their own,
+this will not rewind the git branch on the dgit git server.
+Other dgit users will then see your push
+(with a warning message from dgit)
+even though the maintainer wanted to abolish it.
+Such users might unwittingly reintroduce your changes.
+
+If this situation arises,
+someone should make a suitable dgit push
+to update the contents of dgit-repos
+to a version without the controversial changes.
+.TP
.BR --dgit-view-save= \fIbranch\fR|\fIref\fR
Specifies that when a split view quilt mode is in operation,
and dgit calculates