summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xtests/tests/debpolicy-dbretry2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 1b747fe..93ce3d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -28,6 +28,9 @@ dgit (1.5~~) unstable; urgency=medium
explicitly in drs-push-rejects test. This avoids date dependencies
which can cause that test to fail on fast computers.
* Remove some spurios .debs from the example_1.0.tar.
+ * Increase sqlite_busy_timeout in debpolicy-dbretry, because
+ zealot is very slow and we need to give the other processes time
+ to rollback and release the lock.
--
diff --git a/tests/tests/debpolicy-dbretry b/tests/tests/debpolicy-dbretry
index d9c2ea2..4122691 100755
--- a/tests/tests/debpolicy-dbretry
+++ b/tests/tests/debpolicy-dbretry
@@ -46,7 +46,7 @@ while ! grep $taint $taintsout; do sleep 0.1; done
DGIT_RPD_TEST_DBLOOP_HOOK='
print STDERR "DBLOOP HOOK $sleepy\n";
- $poldbh->sqlite_busy_timeout(500);
+ $poldbh->sqlite_busy_timeout(2500);
if ($sleepy > 2) {
system '\''
set -ex