summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Dgit.pm2
-rw-r--r--debian/changelog3
2 files changed, 4 insertions, 1 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index ebf9d7d..d086cbe 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -108,7 +108,7 @@ sub forkcheck_mainprocess () {
sub setup_sigwarn () {
forkcheck_setup();
$SIG{__WARN__} = sub {
- die $_[0] if forkcheck_mainprocess;
+ confess $_[0] if forkcheck_mainprocess;
};
}
diff --git a/debian/changelog b/debian/changelog
index 62d8eed..8d830f0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
dgit (4.5~) unstable; urgency=medium
+ Minor fixes:
+ * "confess" when we die due to a warning, rather than symply dieing.
+
Internal changes:
* Move $playground global to dgit.
* Break git_get_symref out into Dgit.pm.