summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--tests/lib-core3
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2b75575..cfc7b5c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ dgit (6.7~) unstable; urgency=medium
* git-debrebase: Improve ffq head recording message.
* git-debrebase: Better (less copious by default) debug output.
* git-debrebase: Do not bail making patches if there aren't any.
+ * test suite: Set DEBFULLNAME
--
diff --git a/tests/lib-core b/tests/lib-core
index 724c8ac..4550b9e 100644
--- a/tests/lib-core
+++ b/tests/lib-core
@@ -25,8 +25,9 @@ t-set-using-tmp () {
export DGIT_TEST_DUMMY_DIR=$tmp
export DGIT_TEST_TMP=$tmp
export GNUPGHOME=$tmp/nonexistent
+ export DEBFULLNAME='dgit test git user'
git config --global user.email 'dgit-test@debian.example.net'
- git config --global user.name 'dgit test git user'
+ git config --global user.name "$DEBFULLNAME"
git config --global protocol.ext.allow always
}