summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit3
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 81059b5..00cee5f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ dgit (4.1~) experimental; urgency=medium
Other improvements to dgit:
* New print-dpkg-source-ignores option to print the big rune
you need to pass to dpkg-source to make it work exactly the right.
+ * Properly shell-quote the --git-builder argument to gbp.
Documentation:
* dgit-user(7): Provide information about how to use sbuild.
diff --git a/dgit b/dgit
index 3c94f03..9834d03 100755
--- a/dgit
+++ b/dgit
@@ -6072,7 +6072,8 @@ sub cmd_gbp_build {
}
my @cmd = opts_opt_multi_cmd @gbp_build;
- push @cmd, (qw(-us -uc --git-no-sign-tags), "--git-builder=@dbp");
+ push @cmd, (qw(-us -uc --git-no-sign-tags),
+ "--git-builder=".(shellquote @dbp));
if ($gbp_make_orig) {
my $priv = dgit_privdir();