summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xtests/ssh5
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5a543d7..ff334e4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (0.19~experimental1) experimental; urgency=low
Testing facilities:
* Provide "test-dummy" distro with "dummycat" access method.
+ * Provide fake "ssh" program in tests/ which does nothing much.
--
diff --git a/tests/ssh b/tests/ssh
new file mode 100755
index 0000000..9481a1e
--- /dev/null
+++ b/tests/ssh
@@ -0,0 +1,5 @@
+#!/bin/sh
+set -e
+cd /
+userhost="$1"; shift
+exec sh -c "$*"