summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit1
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index cca9feb..5d37f96 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,8 @@ dgit (3.0~) unstable; urgency=medium
suite and distro more reliably and consistently.
* Parsing of extended Dgit fields by import-dsc was broken;
and is now fixed even for more-extended ones.
+ * dgit clone-dgit-repos-server uses readonly access.
+ Closes:#850521.
Minor new feature:
* distro alias facility in config space. (Primarily for testing.)
diff --git a/dgit b/dgit
index 8c9765e..3b4313b 100755
--- a/dgit
+++ b/dgit
@@ -6156,6 +6156,7 @@ sub cmd_clone_dgit_repos_server {
badusage "need destination argument" unless @ARGV==1;
my ($destdir) = @ARGV;
$package = '_dgit-repos-server';
+ local $access_forpush = 0;
my @cmd = (@git, qw(clone), access_giturl(), $destdir);
debugcmd ">",@cmd;
exec @cmd or fail "exec git clone: $!\n";