summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit5
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index fb17175..4c354a4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,9 @@ dgit (2.9~) unstable; urgency=low
* New option --dgit-view-save= for split view quilt modes.
In particular, means that the output of a split view quilt-fixup
is left somewhere useful.
+ * dgit clone: Set timestamps in cloned tree to a single unified time.
+ This makes it less likely that the user will trip over any
+ timestamp-dependent FTBFS bugs (eg #842452).
--
diff --git a/dgit b/dgit
index 3e746d2..efd8963 100755
--- a/dgit
+++ b/dgit
@@ -2869,6 +2869,11 @@ sub clone ($) {
}
setup_new_tree();
runcmd @git, qw(reset --hard), lrref();
+ runcmd qw(bash -ec), <<'END';
+ set -o pipefail
+ git ls-tree -r --name-only -z HEAD | \
+ xargs -0r touch -r . --
+END
printdone "ready for work in $dstdir";
}