summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit7
2 files changed, 7 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d0b59a..04328fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ dgit (3.3~) unstable; urgency=medium
* dgit: Remove a leftover debugging print.
* dgit: Set default dsc import distro when there is no Dgit field.
* dgit: Set default dsc import distro when suppressing Dgit field.
+ * dgit: Option parsing: Fix undefined $suite in some import-dsc.
+ Closes:#851213.
Packaging:
* Remove redundant Recommends on libtext-iconv-perl.
diff --git a/dgit b/dgit
index f4a470d..4b088db 100755
--- a/dgit
+++ b/dgit
@@ -6119,6 +6119,11 @@ sub cmd_import_dsc {
unless forceing [qw(import-dsc-with-dgit-field)];
parse_dsc_field_def_dsc_distro();
+ $isuite = 'DGIT-IMPORT-DSC';
+ $idistro //= $dsc_distro;
+
+ notpushing();
+
if (defined $dsc_hash) {
progress "dgit: import-dsc of .dsc with Dgit field, using git hash";
resolve_dsc_field_commit undef, undef;
@@ -6155,8 +6160,6 @@ Specify +$specbranch to overwrite, discarding existing history
END
if $oldhash && !$force;
- notpushing();
-
my @dfi = dsc_files_info();
foreach my $fi (@dfi) {
my $f = $fi->{Filename};