summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit7
2 files changed, 7 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b8809bc..682a44f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ dgit (3.11~) unstable; urgency=medium
Closes:#867693.
* dgit: Cope if the archive server sends an HTTP redirect,
by passing -L to curl. Closes:#867185,#867309.
+ * dgit: rpush: Honour local git config from build host working
+ tree.
* test suite: Cope with git restricting ext:: protocols.
--
diff --git a/dgit b/dgit
index 47c8919..a009e41 100755
--- a/dgit
+++ b/dgit
@@ -4542,7 +4542,7 @@ sub cmd_push {
#---------- remote commands' implementation ----------
-sub cmd_remote_push_build_host {
+sub pre_remote_push_build_host {
my ($nrargs) = shift @ARGV;
my (@rargs) = @ARGV[0..$nrargs-1];
@ARGV = @ARGV[$nrargs..$#ARGV];
@@ -4572,11 +4572,14 @@ sub cmd_remote_push_build_host {
" but invocation host has $vsnwant"
unless defined $protovsn;
- responder_send_command("dgit-remote-push-ready $protovsn");
changedir $dir;
+}
+sub cmd_remote_push_build_host {
+ responder_send_command("dgit-remote-push-ready $protovsn");
&cmd_push;
}
+sub pre_remote_push_responder { pre_remote_push_build_host(); }
sub cmd_remote_push_responder { cmd_remote_push_build_host(); }
# ... for compatibility with proto vsn.1 dgit (just so that user gets
# a good error message)