summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdgit4
2 files changed, 4 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 1c944a7..33b627e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
dgit (2.4~) unstable; urgency=low
- *
+ * dgit gbp-build: No longer invent a --git-debian-branch option.
+ Usually the user is a maintainer using split brain, and we should rely
+ on their own gbp configuration to specify the right check.
+ Closes:#841100.
--
diff --git a/dgit b/dgit
index 2cbb2fd..c03c031 100755
--- a/dgit
+++ b/dgit
@@ -4853,10 +4853,6 @@ sub cmd_gbp_build {
}
maybe_unapply_patches_again();
if ($wantsrc < 2) {
- unless (grep { m/^--git-debian-branch|^--git-ignore-branch/ } @ARGV) {
- canonicalise_suite();
- push @cmd, "--git-debian-branch=".lbranch();
- }
push @cmd, changesopts();
runcmd_ordryrun_local @cmd, @ARGV;
}