summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tests/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile b/tests/Makefile
index 88bc0a0..31eb7b6 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -11,11 +11,11 @@ all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
tests/tmp/%.ok: tests/tests/%
ifeq ($(DGIT_TEST_RETRY_COUNT),)
- tests/tests/$* >tests/tmp/$*.log 2>&1
+ $(DGIT_TEST_RUN_PFX) tests/tests/$* >tests/tmp/$*.log 2>&1
else
@for retry in $$( seq 1 $(DGIT_TEST_RETRY_COUNT) ); do \
echo "[$$retry] $*"; \
- tests/tests/$* >tests/tmp/$*.$$retry.log 2>&1; \
+ $(DGIT_TEST_RUN_PFX) tests/tests/$* >tests/tmp/$*.$$retry.log 2>&1; \
rc=$$?; \
if [ $$rc = 0 ]; then exit 0; fi; \
echo >&2 "[$$retry] $* TEST FAILED $$rc"; \