summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xtests/tests/protocol-compat4
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 04328fe..dfd59b7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ dgit (3.3~) unstable; urgency=medium
* Move default dsc distro config setting to lib. We need this
for the .dscs we have in tests/pkg-srcs/.
* test suite: defdistro-import-dsc: Drop this test.
+ * test suite: protocol-compat: check that we use the right distro
+ information when importing.
* test suite: Internal change: fix handling of nonempty distro=
--
diff --git a/tests/tests/protocol-compat b/tests/tests/protocol-compat
index 59e8d65..fcbeedb 100755
--- a/tests/tests/protocol-compat
+++ b/tests/tests/protocol-compat
@@ -6,6 +6,9 @@ set -e
t-setup-import examplegit
t-tstunt-parsechangelog
+t-git-config dgit.default.distro foreign
+t-git-config dgit-distro.foreign.cmd-git false
+
prep () {
dscf=$tmp/mirror/pool/main/example_$v.dsc
}
@@ -23,6 +26,7 @@ check () {
$1
+ local distro=''
t-dgit import-dsc $dscf +imported
t-ref-same refs/heads/imported
cd ..