summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit5
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4bfbca2..0c80ccf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
dgit (3.10~) unstable; urgency=medium
- *
+ Bugfixes:
+ * dgit: Copy several user.* settings from main tree git local config
+ to dgit private workarea. Closes:#853085.
--
diff --git a/dgit b/dgit
index 9cdf96b..7ffbb89 100755
--- a/dgit
+++ b/dgit
@@ -1699,6 +1699,11 @@ sub prep_ud (;$) {
sub mktree_in_ud_here () {
runcmd qw(git init -q);
runcmd qw(git config gc.auto 0);
+ foreach my $copy (qw(user.email user.name user.useConfigOnly)) {
+ my $v = $gitcfgs{local}{$copy};
+ next unless $v;
+ runcmd qw(git config), $copy, $_ foreach @$v;
+ }
rmtree('.git/objects');
symlink '../../../../objects','.git/objects' or die $!;
setup_gitattrs(1);