summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
-rw-r--r--dgit-maint-merge.7.pod2
3 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 00cee5f..6946a2a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ dgit (4.1~) experimental; urgency=medium
bugs; the tests for this are not very comprehensive. And
worktrees on different filesystems may not work; that's a
matter for the future. Closes:#868515.
+ * Change the dpkg-source -i argument to exclude exactly the right
+ set of things. (Sadly this is not a simple rune.)
Other improvements to dgit:
* New print-dpkg-source-ignores option to print the big rune
diff --git a/dgit b/dgit
index 9834d03..248a7cb 100755
--- a/dgit
+++ b/dgit
@@ -100,7 +100,7 @@ our $git_authline_re = '^([^<>]+) \<(\S+)\> (\d+ [-+]\d+)$';
our $splitbraincache = 'dgit-intern/quilt-cache';
our $rewritemap = 'dgit-rewrite/map';
-our @dpkg_source_ignores = qw(-i\.git/ -I.git);
+our @dpkg_source_ignores = qw(-i(?:^|/)\.git(?:/|$) -I.git);
our (@git) = qw(git);
our (@dget) = qw(dget);
diff --git a/dgit-maint-merge.7.pod b/dgit-maint-merge.7.pod
index df1f953..901707e 100644
--- a/dgit-maint-merge.7.pod
+++ b/dgit-maint-merge.7.pod
@@ -209,7 +209,7 @@ Then make new upstream tags available:
Now you simply need to ensure that your git HEAD is dgit-compatible,
i.e., it is exactly what you would get if you ran
-B<dpkg-buildpackage -i'\.git/' -I.git -S>
+B<dpkg-buildpackage -i'(?:^|/)\.git(?:/|$)' -I.git -S>
and then unpacked the resultant source package.
=for dgit-test dpkg-source-ignores end