summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit2
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 846fe23..850681b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,9 @@ dgit (2.13~) unstable; urgency=medium
stretch. Closes:#848901.
* Improve "cannot represent change" message: print the git old and new
modes too.
+ * Import fix: Switch back to unpa branch on patch import iterations.
+ In particular, do not fail utterly if dpkg-source and gbp disagree.
+ Closes:#848843.
--
diff --git a/dgit b/dgit
index acb4563..1e7c923 100755
--- a/dgit
+++ b/dgit
@@ -2367,6 +2367,8 @@ END
my $path = $ENV{PATH} or die;
foreach my $use_absurd (qw(0 1)) {
+ runcmd @git, qw(checkout -q unpa);
+ runcmd @git, qw(update-ref -d refs/heads/patch-queue/unpa);
local $ENV{PATH} = $path;
if ($use_absurd) {
chomp $@;