summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xabsurd/git8
-rw-r--r--debian/changelog1
2 files changed, 9 insertions, 0 deletions
diff --git a/absurd/git b/absurd/git
index 7d3ff94..0f562b5 100755
--- a/absurd/git
+++ b/absurd/git
@@ -95,7 +95,15 @@ END
printf "%s\n" "$omgwtf" >debian/patches/series
printf "%s\n" "$patch" >>debian/patches/series
+# Just in case some joker tries to patch .git/something
+mv .git ../.git
+set +e
dpkg-source --before-build .
+rc=$?
+set -e
+rm -rf .git
+mv ../.git .
+test $rc = 0
rm -f $omgwtf debian/patches/$omgwtf
diff --git a/debian/changelog b/debian/changelog
index e26c4de..d4e18e6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -23,6 +23,7 @@ dgit (2.12~) unstable; urgency=medium
on a patch during .dsc import. Apropos of #848391.
* Do not fail to import a .dsc containing patches which patch files
multiple times, due to #848611. Closes:#848391.
+ * Do not fail to import a .dsc containing patches to .git/ (!)
Test suite:
* Provide and use stunt lintian and debuild, to avoid lintian