summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile12
-rw-r--r--NOTES46
-rw-r--r--TODO19
-rw-r--r--debian/changelog6
-rwxr-xr-xdgit609
-rw-r--r--dgit.1244
6 files changed, 760 insertions, 176 deletions
diff --git a/Makefile b/Makefile
index ed51774..fc49cd0 100644
--- a/Makefile
+++ b/Makefile
@@ -19,17 +19,25 @@
INSTALL=install
INSTALL_DIR=$(INSTALL) -d
INSTALL_PROGRAM=$(INSTALL) -m 755
+INSTALL_DATA=$(INSTALL) -m 644
+
prefix?=/usr/local
+bindir=$(prefix)/bin
+mandir=$(prefix)/share/man
+man1dir=$(mandir)/man1
+
PROGRAMS=dgit
+MAN1PAGES=dgit.1
all:
install: installdirs
- $(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(prefix)/bin
+ $(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(bindir)
+ $(INSTALL_DATA) $(MAN1PAGES) $(DESTDIR)$(man1dir)
installdirs:
- $(INSTALL_DIR) $(DESTDIR)$(prefix)/bin
+ $(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
check installcheck:
diff --git a/NOTES b/NOTES
index 1e94ba0..192348c 100644
--- a/NOTES
+++ b/NOTES
@@ -1,37 +1,9 @@
-New field in dsc
- specifies
- commit hash corresponding to the thing uploaded
- optional commit hash corresponding to pristine tar
- Vcs-git-master: <url>#commit
-
-dgit clone
- fetches dsc
- clones repo from alioth
- repros commit if nec. (if no hash in current dsc, check that
- dsc is after git head and make synthetic commit, otherwise
- complain)
-
-dgit fetch
- as above
-
-dgit push
- after git-buildpackage --tag (but no sign)
- check repo is clean and tag is made
- signs tag
- debsign
- push to alioth (perhaps with merge -s ours)
- to "uploading" tag or branch
- <suite>
- upload/<suite>
- dput
- push to alioth to main tag or branch
-
-where on alioth upstream
-
-rc bugs for
- server(s?) not reachable
- mismatch
-
-?git-buildpackage
-? adds field for master commit hash
-? adds field for pristine tar
+remote is dgit
+ can do fetch thing?
+ push is deliberately broken?
+
+remote refs
+ refs/dgit/<suite>
+local refs
+ refs/heads/<suite>
+ refs/remotes/dgit/<suite>
diff --git a/TODO b/TODO
index 8deefee..3f7ed25 100644
--- a/TODO
+++ b/TODO
@@ -1,17 +1,4 @@
-Download orig.tar.gz even if archive has hash
+Vcs-Dgit-Master: <commit>
+ specifies commit hash corresponding to the thing uploaded
+ optional commit hash corresponding to pristine tar??
-Fix branch names to contain dgit
-
-Cope with outside-main things (rmadison does not print pool path)
-
-Cope with non-Debian archives
-
-Make it possible to do dgit clone / fetch anonymously
-
-Archive agility. Archive needs to specify (a) way to get versions
-and paths in archive for dscs (b) unpriv pull location (c) priv
-push location
-
-Support Format 3.0 (quilt)
-
-Push access for DMs.
diff --git a/debian/changelog b/debian/changelog
index cc596f3..7e2b85f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (0.2) experimental; urgency=low
+
+ * New version which might actually work but probably won't.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 16 Aug 2013 16:52:17 +0100
+
dgit (0.1) experimental; urgency=low
* Initial experimental (partial) version.
diff --git a/dgit b/dgit
index a18f45c..e4b1177 100755
--- a/dgit
+++ b/dgit
@@ -26,23 +26,45 @@ use Dpkg::Control::Hash;
use File::Path;
use POSIX;
-open DEBUG, ">&STDERR" or die $!;
-
-our $mirror = 'http://mirror.relativity.greenend.org.uk/mirror/debian-ftp/';
our $suite = 'sid';
our $package;
-our $aliothname = 'iwj@git.debian.org';
-our $aliothpath = '/git/dgit-test';
-our $alioth_git = "git+ssh://$aliothname/$aliothpath";
-our $alioth_sshtestbodge = [$aliothname,$aliothpath];
+our $sign = 1;
+our $dryrun = 0;
+our $changesfile;
+our $new_package = 0;
+our $existing_package = 'dpkg';
-our (@dget_opts) = qw(-u);
+our %format_ok = map { $_=>1 } ("1.0","3.0 (native)","3.0 (quilt)");
-our $remotename = 'dgit';
+our (@git) = qw(git);
+our (@dget) = qw(dget);
+our (@dput) = qw(dput);
+our (@debsign) = qw(debsign);
+our $keyid;
+
+our $debug = 0;
+open DEBUG, ">/dev/null" or die $!;
+
+our %opts_opt_map = ('dget' => \@dget,
+ 'dput' => \@dput,
+ 'debsign' => \@debsign);
-sub mainbranch () { return "$suite"; }
-sub uploadbranch () { return "upload/$suite"; }
+our $remotename = 'dgit';
+our $ourdscfield = 'Vcs-Dgit-Master';
+our $branchprefix = 'dgit';
+
+sub lbranch () { return "$branchprefix/$suite"; }
+my $lbranch_re = '^refs/heads/'.$branchprefix.'/([^/.]+)$';
+sub lref () { return "refs/heads/".lbranch(); }
+sub lrref () { return "refs/remotes/$remotename/$suite"; }
+sub rrref () { return "refs/$branchprefix/$suite"; }
+sub debiantag ($) { return "debian/$_[0]"; }
+
+sub fetchspec () {
+ local $suite = '*';
+ return "+".rrref().":".lrref();
+}
our $ua;
@@ -51,7 +73,7 @@ sub url_get {
$ua = LWP::UserAgent->new();
$ua->env_proxy;
}
- print DEBUG "fetching @_...\n";
+ print "downloading @_...\n";
my $r = $ua->get(@_) or die $!;
die "$_[0]: ".$r->status_line."; failed.\n" unless $r->is_success;
return $r->decoded_content();
@@ -59,22 +81,119 @@ sub url_get {
our ($dscdata,$dscurl,$dsc);
+sub printcmd {
+ my $fh = shift @_;
+ my $intro = shift @_;
+ print $fh $intro or die $!;
+ local $_;
+ foreach my $a (@_) {
+ $_ = $a;
+ if (s{['\\]}{\\$&}g || m{\s} || m{[^-_./0-9a-z]}i) {
+ print $fh " '$_'" or die $!;
+ } else {
+ print $fh " $_" or die $!;
+ }
+ }
+ print $fh "\n" or die $!;
+}
+
sub runcmd {
+ printcmd(\*DEBUG,"+",@_) if $debug>0;
$!=0; $?=0;
die "@_ $! $?" if system @_;
}
-sub cmdoutput {
+sub cmdoutput_errok {
+ die Dumper(\@_)." ?" if grep { !defined } @_;
+ printcmd(\*DEBUG,"|",@_) if $debug>0;
open P, "-|", @_ or die $!;
my $d;
$!=0; $?=0;
{ local $/ = undef; $d = <P>; }
die if P->error;
- close P or die "@_ $? $!";
+ close P or return undef;
chomp $d;
return $d;
}
+sub cmdoutput {
+ my $d = cmdoutput_errok @_;
+ defined $d or die "@_ $? $!";
+ return $d;
+}
+
+sub dryrun_report {
+ printcmd(\*STDOUT,"#",@_);
+}
+
+sub runcmd_ordryrun {
+ if (!$dryrun) {
+ runcmd @_;
+ } else {
+ dryrun_report @_;
+ }
+}
+
+our %defcfg = ('dgit.default.distro' => 'debian',
+ 'dgit.default.username' => '',
+ 'dgit.default.archive-query-default-component' => 'main',
+ 'dgit.default.ssh' => 'ssh',
+ 'dgit-distro.debian.git-host' => 'git.debian.org',
+ 'dgit-distro.debian.git-proto' => 'git+ssh://',
+ 'dgit-distro.debian.git-path' => '/git/dgit-repos',
+ 'dgit-distro.debian.git-check' => 'ssh-cmd',
+ 'dgit-distro.debian.git-create' => 'ssh-cmd',
+ 'dgit-distro.debian.mirror' => 'http://ftp.debian.org/debian/');
+
+sub cfg {
+ foreach my $c (@_) {
+ my $v;
+ {
+ local ($debug) = $debug-1;
+ $v = cmdoutput_errok(@git, qw(config --), $c);
+ };
+ if ($?==0) {
+ chomp $v;
+ return $v;
+ } elsif ($?!=256) {
+ die "$c $?";
+ }
+ my $dv = $defcfg{$c};
+ return $dv if defined $dv;
+ }
+ return undef;
+}
+
+sub access_distro () {
+ return cfg("dgit-suite.$suite.distro",
+ "dgit.default.distro");
+}
+
+sub access_cfg ($) {
+ my ($key) = @_;
+ my $distro = access_distro();
+ my $value = cfg("dgit-distro.$distro.$key",
+ "dgit.default.$key");
+ return $value;
+}
+
+sub access_gituserhost () {
+ my $user = access_cfg('git-user');
+ my $host = access_cfg('git-host');
+ return defined($user) && length($user) ? "$user\@$host" : $host;
+}
+
+sub access_giturl () {
+ my $url = access_cfg('git-url');
+ if (!defined $url) {
+ $url =
+ access_cfg('git-proto').
+ access_gituserhost().
+ access_cfg('git-path');
+ }
+ return "$url/$package.git";
+}
+
sub parsecontrol {
my $c = Dpkg::Control::Hash->new();
$c->load(@_) or return undef;
@@ -83,53 +202,100 @@ sub parsecontrol {
sub parsechangelog {
my $c = Dpkg::Control::Hash->new();
- my $p = new IO::File '-|', qw(dpkg-parsechangelog) or die $!;
+ my $p = new IO::Handle;
+ open $p, '-|', qw(dpkg-parsechangelog) or die $!;
$c->parse($p);
$?=0; $!=0; close $p or die "$! $?";
return $c;
}
-sub get_archive_dsc () {
- my $rmad = cmdoutput qw(rmadison -asource),"-s$suite",$package;
- $rmad =~ m/^ \s*( [^ \t|]+ )\s* \|
- \s*( [^ \t|]+ )\s* \|
+our %rmad;
+
+sub archive_query () {
+ my $query = access_cfg('archive-query');
+ $query ||= "madison:".access_distro();
+ $query =~ s/^(\w+):// or die "$query ?";
+ my $proto = $1;
+ my $url = $'; #';
+ die unless $proto eq 'madison';
+ $rmad{$package} ||= cmdoutput
+ qw(rmadison -asource),"-s$suite","-u$url",$package;
+ my $rmad = $rmad{$package};
+ if (!length $rmad) {
+ return ();
+ }
+ $rmad =~ m{^ \s*( [^ \t|]+ )\s* \|
\s*( [^ \t|]+ )\s* \|
- \s*( [^ \t|]+ )\s* /x or die "$rmad $?";
+ \s*( [^ \t|/]+ )(?:/([^ \t|/]+))? \s* \|
+ \s*( [^ \t|]+ )\s* }x or die "$rmad $?";
$1 eq $package or die "$rmad $package ?";
my $vsn = $2;
- $3 eq $suite or die "$rmad $suite ?";
- $4 eq 'source' or die "$rmad ?";
- # fixme it does not show us the component ?
+ if ($suite ne $3) {
+ # madison canonicalises for us
+ print "canonical suite name for $suite is $3\n";
+ $suite = $3;
+ }
+ my $component;
+ if (defined $4) {
+ $component = $4;
+ } else {
+ $component = access_cfg('archive-query-default-component');
+ }
+ $5 eq 'source' or die "$rmad ?";
my $prefix = substr($package, 0, $package =~ m/^l/ ? 4 : 1);
- $dscurl = "$mirror/pool/main/$prefix/$package/${package}_$vsn.dsc";
-#print DEBUG Dumper($pdodata, $&, $dscurl);
+ my $subpath = "/pool/$component/$prefix/$package/${package}_$vsn.dsc";
+ return ($vsn,$subpath);
+}
+
+sub canonicalise_suite () {
+ archive_query() or die;
+}
+
+sub get_archive_dsc () {
+ my ($vsn,$subpath) = archive_query();
+ if (!defined $vsn) { $dsc=undef; return undef; }
+ $dscurl = access_cfg('mirror').$subpath;
$dscdata = url_get($dscurl);
my $dscfh = new IO::File \$dscdata, '<' or die $!;
-#print DEBUG Dumper($dscdata, $dscfh);
+ print DEBUG Dumper($dscdata) if $debug>1;
$dsc = Dpkg::Control::Hash->new(allow_pgp=>1);
$dsc->parse($dscfh, 'dsc') or die "parsing of $dscurl failed\n";
-#print DEBUG Dumper($dsc);
+ print DEBUG Dumper($dsc) if $debug>1;
my $fmt = $dsc->{Format};
- die "unsupported format $fmt, sorry\n" unless $fmt eq '1.0';
+ die "unsupported format $fmt, sorry\n" unless $format_ok{$fmt};
}
sub check_for_git () {
# returns 0 or 1
- my $cmd=
- "ssh $alioth_sshtestbodge->[0] '".
- " set -e; cd /git/dgit-test;".
- " if test -d $package.git; then echo 1; else echo 0; fi".
- "'";
- #print DEBUG "$cmd\n";
- open P, "$cmd |" or die $!;
- $!=0; $?=0;
- my $r = <P>; close P;
-#print STDERR ">$r<\n";
- die "$r $! $?" unless $r =~ m/^[01]$/;
- return $r+0;
+ my $how = access_cfg('git-check');
+ if ($how eq 'ssh-cmd') {
+ my $r= cmdoutput
+ (access_cfg('ssh'),access_gituserhost(),
+ " set -e; cd ".access_cfg('git-path').";".
+ " if test -d $package.git; then echo 1; else echo 0; fi");
+ print DEBUG "got \`$r'\n";
+ die "$r $! $?" unless $r =~ m/^[01]$/;
+ return $r+0;
+ } else {
+ die "unknown git-check $how ?";
+ }
+}
+
+sub create_remote_git_repo () {
+ my $how = access_cfg('git-create');
+ if ($how eq 'ssh-cmd') {
+ runcmd_ordryrun
+ (access_cfg('ssh'),access_gituserhost(),
+ "set -e; cd ".access_cfg('git-path').";".
+ " mkdir -p $package.git;".
+ " cd $package.git;".
+ " if ! test -d objects; then git init --bare; fi");
+ } else {
+ die "unknown git-create $how ?";
+ }
}
-our ($dsc_hash,$lastupl_hash);
+our ($dsc_hash,$upload_hash);
our $ud = '.git/dgit/unpack';
@@ -151,29 +317,38 @@ sub mktree_in_ud_from_only_subdir () {
runcmd qw(git init -q);
rmtree('.git/objects');
symlink '../../../../objects','.git/objects' or die $!;
- runcmd qw(git add -Af);
- my $tree = cmdoutput qw(git write-tree);
+ runcmd @git, qw(add -Af);
+ my $tree = cmdoutput @git, qw(write-tree);
chomp $tree; $tree =~ m/^\w+$/ or die "$tree ?";
return ($tree,$dir);
}
+sub dsc_files () {
+ map {
+ m/^\w+ \d+ (\S+)$/ or die "$_ ?";
+ $1;
+ } grep m/\S/, split /\n/, ($dsc->{'Checksums-Sha256'} || $dsc->{Files});
+}
+
+sub is_orig_file ($) {
+ local ($_) = @_;
+ m/\.orig(?:-\w+)?\.tar\.\w+$/;
+}
+
sub generate_commit_from_dsc () {
prep_ud();
chdir $ud or die $!;
my @files;
- foreach (split /\n/, ($dsc->{'Checksums-Sha256'} || $dsc->{Files})) {
- next unless m/\S/;
- m/^\w+ \d+ (\S+)$/ or die "$_ ?";
- my $f = $1;
+ foreach my $f (dsc_files()) {
die if $f =~ m#/|^\.|\.dsc$|\.tmp$#;
push @files, $f;
link "../../../$f", $f
or $!==&ENOENT
or die "$f $!";
}
- runcmd qw(dget), @dget_opts, qw(--), $dscurl;
- foreach my $f (grep { m/\.tar\.gz$/ } @files) {
- link $f, "../../../$f"
+ runcmd @dget, qw(--), $dscurl;
+ foreach my $f (grep { is_orig_file($_) } @files) {
+ link $f, "../../../../$f"
or $!==&EEXIST
or die "$f $!";
}
@@ -187,7 +362,7 @@ sub generate_commit_from_dsc () {
$authline =~ m/^[^<>]+ \<\S+\> \d+ [-+]\d+$/ or die $authline;
open C, ">../commit.tmp" or die $!;
print C "tree $tree\n" or die $!;
- print C "parent $lastupl_hash\n" or die $! if defined $lastupl_hash;
+ print C "parent $upload_hash\n" or die $! if $upload_hash;
print C <<END or die $!;
author $authline
committer $authline
@@ -197,17 +372,17 @@ $clogp->{Changes}
# imported by dgit from the archive
END
close C or die $!;
+ my $commithash = cmdoutput @git, qw(hash-object -w -t commit ../commit.tmp);
print "synthesised git commit from .dsc $clogp->{Version}\n";
- my $commithash = cmdoutput qw(git hash-object -w -t commit ../commit.tmp);
chdir '../../../..' or die $!;
- cmdoutput qw(git update-ref -m),"dgit synthesise $clogp->{Version}",
+ cmdoutput @git, qw(update-ref -m),"dgit synthesise $clogp->{Version}",
'DGIT_ARCHIVE', $commithash;
- cmdoutput qw(git log -n2), $commithash;
+ cmdoutput @git, qw(log -n2), $commithash;
# ... gives git a chance to complain if our commit is malformed
my $outputhash = $commithash;
- if (defined $lastupl_hash) {
+ if ($upload_hash) {
chdir "$ud/$dir" or die $!;
- runcmd qw(git reset --hard), $lastupl_hash;
+ runcmd @git, qw(reset --hard), $upload_hash;
runcmd qw(sh -ec), 'dpkg-parsechangelog >>../changelogold.tmp';
my $oldclogp = Dpkg::Control::Hash->new();
$oldclogp->parse('../changelogold.tmp','previous changelog') or die;
@@ -232,129 +407,321 @@ END
return $outputhash;
}
-my $lastupl_ref = "refs/remotes/$remotename/upload/$suite";
+sub ensure_we_have_orig () {
+ foreach my $f (dsc_files()) {
+ next unless is_orig_file($f);
+ if (stat "../$f") {
+ die "$f ?" unless -f _;
+ } else {
+ die "$f $!" unless $!==&ENOENT;
+ }
+ my $origurl = $dscurl;
+ $origurl =~ s{/[^/]+$}{};
+ $origurl .= "/$f";
+ die "$f ?" unless $f =~ m/^${package}_/;
+ die "$f ?" if $f =~ m#/#;
+ runcmd_ordryrun qw(sh -ec),'cd ..; exec "$@"','x',
+ @dget,'--',$origurl;
+ }
+}
sub rev_parse ($) {
- return cmdoutput qw(git rev-parse --), "$_[0]~0";
+ return cmdoutput @git, qw(rev-parse), "$_[0]~0";
}
sub is_fast_fwd ($$) {
my ($ancestor,$child) = @_;
- my $mb = cmdoutput qw(git merge-base), $dsc_hash, $lastupl_hash;
+ my $mb = cmdoutput @git, qw(merge-base), $dsc_hash, $upload_hash;
return rev_parse($mb) eq rev_parse($ancestor);
}
+sub git_fetch_us () {
+ die "cannot dry run with fetch" if $dryrun;
+ runcmd @git, qw(fetch),access_giturl(),fetchspec();
+}
+
sub fetch_from_archive () {
- # ensures that $lastupl_ref is what is actually in the archive,
+ # ensures that lrref() is what is actually in the archive,
# one way or another
- $!=0; $lastupl_hash = `git show-ref --heads $lastupl_ref`;
- die $! if $!;
- die $? unless ($?==0 && chomp $lastupl_hash)
- or ($?==128 && !length $lastupl_hash);
+ get_archive_dsc() or return 0;
+ $dsc_hash = $dsc->{$ourdscfield};
+ if (defined $dsc_hash) {
+ $dsc_hash =~ m/\w+/ or die "$dsc_hash $?";
+ $dsc_hash = $&;
+ print "last upload to archive specified git hash\n";
+ } else {
+ print "last upload to archive has NO git hash\n";
+ }
+
+ $!=0; $upload_hash =
+ cmdoutput_errok @git, qw(show-ref --heads), lrref();
+ if ($?==0) {
+ die unless chomp $upload_hash;
+ } elsif ($?==256) {
+ $upload_hash = '';
+ } else {
+ die $?;
+ }
my $hash;
if (defined $dsc_hash) {
+ die "missing git history even though dsc has hash"
+ unless $upload_hash;
$hash = $dsc_hash;
+ ensure_we_have_orig();
} else {
$hash = generate_commit_from_dsc();
}
- if ($lastupl_hash) {
+ if ($upload_hash) {
die "not fast forward on last upload branch!".
" (archive's version left in DGIT_ARCHIVE)"
- unless is_fast_fwd($lastupl_hash, $dsc_hash);
+ unless is_fast_fwd($dsc_hash, $upload_hash);
}
- if ($lastupl_ref ne $hash) {
- cmdoutput qw(git update-ref -m), 'dgit fetch', $lastupl_ref, $hash;
+ if ($upload_hash ne $hash) {
+ my @upd_cmd = (@git, qw(update-ref -m), 'dgit fetch', lrref(), $hash);
+ if (!$dryrun) {
+ cmdoutput @upd_cmd;
+ } else {
+ dryrun_report @upd_cmd;
+ }
}
+ return 1;
}
-sub clone () {
- get_archive_dsc();
- $dsc_hash = $dsc->{'Vcs-git-master'};
- if (defined $dsc_hash) {
- $dsc_hash =~ m/\w+/ or die "$dsc_hash $?";
- $dsc_hash = $&;
- print "last upload to archive specified git hash\n";
- } else {
- print "last upload to archive has NO git hash\n";
- }
- my $dstdir = "$package";
+sub clone ($) {
+ my ($dstdir) = @_;
+ die "dry run makes no sense with clone" if $dryrun;
+ mkdir $dstdir or die "$dstdir $!";
+ chdir "$dstdir" or die "$dstdir $!";
+ runcmd @git, qw(init -q);
+ runcmd @git, qw(config), "remote.$remotename.fetch", fetchspec();
+ open H, "> .git/HEAD" or die $!;
+ print H "ref: ".lref()."\n" or die $!;
+ close H or die $!;
+ runcmd @git, qw(remote add), 'origin', access_giturl();
if (check_for_git()) {
- print "cloning existing git history\n";
- runcmd qw(git clone --origin),$remotename, qw(-b), $suite, '--',
- $alioth_git, $dstdir;
- chdir "$dstdir" or die "$dstdir $!";
- fetch_from_archive();
- runcmd qw(git reset --hard), $lastupl_ref;
+ print "fetching existing git history\n";
+ git_fetch_us();
+ runcmd @git, qw(fetch origin);
} else {
- die "missing git history even though dsc has hash" if defined $dsc_hash;
print "starting new git history\n";
- mkdir $dstdir or die "$dstdir $!";
- chdir "$dstdir" or die "$dstdir $!";
- runcmd qw(git init -q);
- open H, "> .git/HEAD" or die $!;
- print H "ref: refs/heads/$suite\n" or die $!;
- close H or die $!;
- runcmd qw(git remote add), $remotename, $alioth_git;
- runcmd "git config branch.$suite.remote $remotename";
- runcmd "git config branch.$suite.merge refs/heads/$suite";
- my $newhash = generate_commit_from_dsc();
- runcmd qw(git reset --hard), $newhash;
}
+ fetch_from_archive() or die;
+ runcmd @git, qw(reset --hard), lrref();
print "ready for work in $dstdir\n";
}
sub fetch () {
-
+ if (check_for_git()) {
+ git_fetch_us();
+ }
+ fetch_from_archive() or die;
+}
+
+sub pull () {
+ fetch();
+ runcmd_ordryrun @git, qw(merge -m),"Merge from $suite [dgit]",
+ lrref();
}
-sub push () {
- runcmd qw(git diff --quiet HEAD);
+sub dopush () {
+ runcmd @git, qw(diff --quiet HEAD);
my $clogp = parsechangelog();
$package = $clogp->{Source};
my $dscfn = "${package}_$clogp->{Version}.dsc";
- stat $dscfn or die "$dscfn $!";
+ stat "../$dscfn" or die "$dscfn $!";
$dsc = parsecontrol("../$dscfn");
prep_ud();
chdir $ud or die $!;
print "checking that $dscfn corresponds to HEAD\n";
runcmd qw(dpkg-source -x --), "../../../../$dscfn";
- my $tree = mktree_in_ud_from_only_subdir();
+ my ($tree,$dir) = mktree_in_ud_from_only_subdir();
chdir '../../../..' or die $!;
- runcmd qw(git diff --exit-code), $tree;
- runcmd qw(git fetch), $alioth_git,
- map { "$_:refs/remotes/$remotename/$_" }
- (mainbranch(), uploadbranch());
- die <<END;
- if (!is_fast_fwd(mainbranch
-xxx introduce remote_lref
-xxx use remote_lref everywhere
-
-fetch from alioth
-do fast forward check and maybe fake merge
-push to uploading
-dput
-push to main
-END
+ runcmd @git, qw(diff --exit-code), $tree;
+#fetch from alioth
+#do fast forward check and maybe fake merge
+# if (!is_fast_fwd(mainbranch
+# runcmd @git, qw(fetch -p ), "$alioth_git/$package.git",
+# map { lref($_).":".rref($_) }
+# (uploadbranch());
+ $dsc->{$ourdscfield} = rev_parse('HEAD');
+ $dsc->save("../$dscfn.tmp") or die $!;
+ if (!$dryrun) {
+ rename "../$dscfn.tmp","../$dscfn" or die "$dscfn $!";
+ } else {
+ print "[new .dsc left in $dscfn.tmp]\n";
+ }
+ if (!$changesfile) {
+ my $pat = "../${package}_$clogp->{Version}_*.changes";
+ my @cs = glob $pat;
+ die "$pat ?" unless @cs==1;
+ ($changesfile) = @cs;
+ }
+ my $tag = debiantag($dsc->{Version});
+ if (!check_for_git()) {
+ create_remote_git_repo();
+ }
+ runcmd_ordryrun @git, qw(push),access_giturl(),"HEAD:".rrref();
+ if ($sign) {
+ my @tag_cmd = (@git, qw(tag -s -m),
+ "Release $dsc->{Version} for $suite [dgit]");
+ push @tag_cmd, qw(-u),$keyid if defined $keyid;
+ push @tag_cmd, $tag;
+ runcmd_ordryrun @tag_cmd;
+ my @debsign_cmd = @debsign;
+ push @debsign_cmd, "-k$keyid" if defined $keyid;
+ push @debsign_cmd, $changesfile;
+ runcmd_ordryrun @debsign_cmd;
+ }
+ runcmd_ordryrun @git, qw(push),access_giturl(),"refs/tags/$tag";
+ my $host = access_cfg('upload-host');
+ my @hostarg = defined($host) ? ($host,) : ();
+ runcmd_ordryrun @dput, @hostarg, $changesfile;
}
sub cmd_clone {
+ parseopts();
+ my $dstdir;
+ die if defined $package;
if (@ARGV==1) {
($package) = @ARGV;
- } elsif (@ARGV==2) {
+ } elsif (@ARGV==2 && $ARGV[1] =~ m#^\w#) {
($package,$suite) = @ARGV;
+ } elsif (@ARGV==2 && $ARGV[1] =~ m#^[./]#) {
+ ($package,$dstdir) = @ARGV;
+ } elsif (@ARGV==3) {
+ ($package,$suite,$dstdir) = @ARGV;
} else {
die;
}
- clone();
+ $dstdir ||= "$package";
+ clone($dstdir);
+}
+
+sub branchsuite () {
+ my $branch = cmdoutput_errok @git, qw(symbolic-ref HEAD);
+ chomp $branch;
+ if ($branch =~ m#$lbranch_re#o) {
+ return $1;
+ } else {
+ return undef;
+ }
+}
+
+sub fetchpullargs () {
+ if (!defined $package) {
+ my $sourcep = parsecontrol('debian/control');
+ $package = $sourcep->{Source};
+ }
+ if (@ARGV==0) {
+ $suite = branchsuite();
+ if (!$suite) {
+ my $clogp = parsechangelog();
+ $suite = $clogp->{Distribution};
+ }
+ canonicalise_suite();
+ print "fetching from suite $suite\n";
+ } elsif (@ARGV==1) {
+ ($suite) = @ARGV;
+ canonicalise_suite();
+ } else {
+ die;
+ }
+}
+
+sub cmd_fetch {
+ parseopts();
+ fetchpullargs();
+ fetch();
+}
+
+sub cmd_pull {
+ parseopts();
+ fetchpullargs();
+ pull();
+}
+
+sub cmd_push {
+ parseopts();
+ die if defined $package;
+ my $clogp = parsechangelog();
+ $package = $clogp->{Source};
+ if (@ARGV==0) {
+ $suite = $clogp->{Distribution};
+ if ($new_package) {
+ local ($package) = $existing_package; # this is a hack
+ canonicalise_suite();
+ }
+ } else {
+ die;
+ }
+ if (fetch_from_archive()) {
+ is_fast_fwd(lrref(), 'HEAD') or die;
+ } else {
+ die unless $new_package;
+ }
+ dopush();
+}
+
+sub cmd_build {
+ # we pass further options and args to git-buildpackage
+ die if defined $package;
+ my $clogp = parsechangelog();
+ $suite = $clogp->{Distribution};
+ $package = $clogp->{Source};
+ runcmd_ordryrun
+ qw(git-buildpackage -us -uc --git-no-sign-tags),
+ '--git-builder=dpkg-buildpackage -i\.git/ -I.git',
+ "--git-debian-branch=".lbranch(),
+ @ARGV;
}
sub parseopts () {
- die if @ARGV && $ARGV[0] =~ m/^\-/;
+ my $om;
+ while (@ARGV) {
+ last unless $ARGV[0] =~ m/^-/;
+ $_ = shift @ARGV;
+ last if m/^--?$/;
+ if (m/^--/) {
+ if (m/^--dry-run$/) {
+ $dryrun=1;
+ } elsif (m/^--no-sign$/) {
+ $sign=0;
+ } elsif (m/^--new$/) {
+ $new_package=1;
+ } elsif (m/^--(\w+)=(.*)/s && ($om = $opts_opt_map{$1})) {
+ $om->[0] = $2;
+ } elsif (m/^--(\w+):(.*)/s && ($om = $opts_opt_map{$1})) {
+ push @$om, $2;
+ } elsif (m/^--existing-package=(.*)/s) {
+ $existing_package = $1;
+ } else {
+ die "$_ ?";
+ }
+ } else {
+ while (m/^-./s) {
+ if (s/^-n/-/) {
+ $dryrun=1;
+ } elsif (s/^-D/-/) {
+ open DEBUG, ">&STDERR" or die $!;
+ $debug++;
+ } elsif (s/^-N/-/) {
+ $new_package=1;
+ } elsif (s/^-c(.*=.*)//s) {
+ push @git, '-c', $1;
+ } elsif (s/^-C(.*)//s) {
+ $changesfile = $1;
+ } elsif (s/^-k(.*)//s) {
+ $keyid=$1;
+ } else {
+ die "$_ ?";
+ }
+ }
+ }
+ }
}
parseopts();
die unless @ARGV;
my $cmd = shift @ARGV;
-parseopts();
{ no strict qw(refs); &{"cmd_$cmd"}(); }
diff --git a/dgit.1 b/dgit.1
new file mode 100644
index 0000000..64a03cf
--- /dev/null
+++ b/dgit.1
@@ -0,0 +1,244 @@
+.TH dgit 1 "" "Debian Project" "dgit"
+.SH NAME
+dgit \- git integration with the Debian archive
+.
+.SH SYNOPSIS
+.B dgit
+[\fIdgit\-opts\fP] \fBclone\fP [\fIdgit\-opts\fP]
+\fIpackage\fP [\fIsuite\fP] [\fB./\fP\fIdir|\fB/\fP\fIdir]
+.br
+.B dgit
+[\fIdgit\-opts\fP] \fBfetch\fP|\fBpull\fP [\fIdgit\-opts\fP]
+[\fIsuite\fP]
+.br
+.B dgit
+[\fIdgit\-opts\fP] \fBbuild\fP
+[\fIgit\-buildpackage\-opts\fP|\fIdpkg\-buildpackage\-opts\fp]
+.br
+.B dgit
+[\fIdgit\-opts\fP] \fBpush\fP [\fIdgit\-opts\fP]
+[\fIsuite\fP]
+.SH DESCRIPTION
+.B dgit
+treats the Debian archive as a version control system, and
+bidirectionally gateways between the archive and git. The git view of
+the package can contain the usual upstream git history, and will be
+augmented by commits representing uploads done by other developers not
+using dgit. This git history is stored in a canonical location known
+as
+.B dgit-repos
+which lives outside the Debian archive (currently, on Alioth).
+
+.B dgit clone
+and
+.B dgit fetch
+consult the archive and dgit-repos and fetch and/or construct the
+git view of the history. With clone, the destination directory (by
+default, the package name in the current directory) will be created,
+and the new directory's `origin' remote will be set up to point to
+the package's dgit-repos tree.
+
+.B dgit build
+runs
+.B git-buildpackage
+with some suitable options. Options after
+.B build
+will be passed on to git-buildpackage. It is not necessary to
+use dgit build; it is OK to use any approach which ensures that
+the generated source package corresponds to the relevant git commit.
+Tagging and signing should be left to dgit push.
+
+.B dgit push
+does an `upload', pushing the current HEAD to the archive (as a source
+package) and to dgit-repos (as git commits). This also involves
+making a signed git tag, and signing the files to be uploaded to the
+archive.
+.SH MODEL AND WORKFLOW
+You may use any suitable git workflow with dgit, provided you
+satisfy dgit's requirements:
+
+dgit maintains a pseudo-remote called
+.BR dgit ,
+with one branch per suite. This remote cannot be used with
+plain git.
+
+The
+.B dgit-repos
+repository for each package contains one ref per suite named
+\fBrefs/dgit/\fR\fIsuite\fR. These should be pushed to only by
+dgit. They are fast forwarding. Each push on this branch
+corresponds to an upload (or attempted upload).
+
+However, it is perfectly fine to have other branches in dgit-repos;
+normally the dgit-repos repo for the package will be accessible via
+the remote name `origin'.
+
+dgit push can operate on any commit which is a descendant of the
+current dgit/suite tip in dgit-repos.
+
+Uploads made by dgit contain an additional field
+.B Vcs-Dgit-Master
+in the source package .dsc. (This is added by dgit push.)
+This specifies a commit (an ancestor of the dgit/suite
+branch) whose tree is identical to the unpacked source upload.
+
+Uploads not made by dgit are represented in git by commits which are
+synthesised by dgit. The tree of each such commit corresponds to the
+unpacked source; the single parent is the last known upload - that is,
+the contents of the dgit/suite branch.
+
+dgit expects repos that it works with to have a
+.B dgit
+remote. This refers to the well-known dgit-repos location
+(currently, the dgit-repos project on Alioth). dgit fetch updates
+the remote tracking branch for dgit/suite.
+.SH OPTIONS
+.TP
+.BR --dry-run | -n
+Go through the motions, fetching all information needed, but do not
+actually update the output(s). For push, dgit does
+the required checks and leaves the new .dsc in a temporary file,
+but does not sign, tag, push or upload.
+.TP
+.BI -k keyid
+Use
+.I keyid
+for signing the tag and the upload.
+.TP
+.BR --no-sign
+does not sign tags or uploads (meaningful only with push).
+.TP
+.TP
+.BI -p package
+Specifies that we should process source package
+.I package
+rather than looking in debian/control or debian/changelog.
+Valid with dgit fetch and dgit pull, only.
+.TP
+.BR -N | --new
+The package may be new in this suite. Without this, dgit will
+refuse to push.
+.TP
+.BI -D
+Prints debugging information to stderr. Repeating the option produces
+more output (currently, up to -DD is meaningfully different).
+.TP
+.BI -c name = value
+Specifies a git configuration option. dgit itself is also controlled
+by git configuration options.
+.TP
+.RI \fB--dget=\fR program |\fB--dput=\fR program |\fB--debsign=\fR program
+Specifies alternative programs to use instead of dget, dput
+or debsign.
+.TP
+.RI \fB--dget:\fR option |\fB--dput:\fR option |\fB--debsign:\fR option
+Specifies a single additional option to pass to dget, dput or
+debsign. Use repeatedly if multiple additional options are required.
+.TP
+.BI -C changesfile
+Specifies the .changes file which is to be uploaded. By default
+dgit push looks for single .changes file in the parent directory whose
+filename suggests it is for the right package and version.
+.TP
+.BI --existing-package= package
+dgit push needs to canonicalise the suite name. But currently
+there is no way to ask the archive to do this without knowing the
+name of an existing package. Without --new we can just use the
+package we are trying to push. But with --new that will not work, so
+we guess that
+.B dpkg
+exists in the target suite. If it doesn't, you can use this option to
+specify a package which does. If the suite is empty, bad luck.
+.SH CONFIGURATION
+dgit looks at the following git config keys to control its behaviour.
+You may set them with git-config (either in system-global or per-tree
+configuration), or provide
+.BI -c key = value
+on the dgit command line.
+.TP
+.BI dgit-suite. suite .distro
+.TP
+.BI dgit.default.distro
+.TP
+.BI dgit.default.username
+.TP
+.BI dgit-distro. distro .git-url
+.TP
+.BI dgit-distro. distro .git-host
+.TP
+.BI dgit-distro. distro .git-proto
+.TP
+.BI dgit-distro. distro .git-path
+.TP
+.BI dgit-distro. distro .git-check
+.TP
+.BI dgit-distro. distro .git-create
+.TP
+.BI dgit-distro. distro .upload-host
+.TP
+.BI dgit-distro. distro .mirror
+.TP
+.BI dgit-distro. distro .archive-query
+.TP
+.BI dgit-distro. distro .archive-query-default-component
+.TP
+.BI dgit-distro. distro .ssh
+.TP
+.BR dgit.default. *
+for each
+.BR dgit-distro. \fIdistro\fR . *
+.SH BUGS
+We should be using some kind of vhost/vpath setup for the git repos on
+alioth, so that they can be moved later if and when this turns out to
+be a good idea.
+
+Debian Policy needs to be updated to describe the new Vcs-Dgit-Master
+field (and to specify that it is an RC bug for that field to refer
+to an unavailable commit).
+
+The method of canonicalising suite names is bizarre. See the
+.B --existing-package
+option for one of the implication.s
+
+dgit push should perhaps do `git push origin', or something similar,
+by default.
+
+The mechanism for checking for and creating per-package repos on
+alioth is a hideous bodge. One consequence is that dgit currently
+only works for people with push access.
+
+Debian Maintainers are currently not able to push, as there is not
+currently any mechanism for determining and honouring the archive's
+ideas about access control. Currently only DDs can push.
+
+dgit's representation of format `3.0 (quilt)' source packages does not
+represent the patch stack. Currently the patch series representation
+cannot round trip through the archive. Ideally dgit would represent a
+quilty package with an origin commit of some kind followed by the
+patch stack as a series of commits followed by a pseudo-merge (to make
+the branch fast-forwarding). This would also mean a new `dgit
+rebase-prep' command or some such to turn such a fast-forwarding
+branch back into a rebasing patch stack, and a `force' option to dgit
+push (perhaps enabled automatically by a note left by rebase-prep)
+which will make the required pseudo-merge.
+
+If the dgit push fails halfway through, it should be restartable and
+idempotent. However this is not true for the git tag operation.
+
+dgit's handling of .orig.tar.gz is not very sophisticated. Ideally
+the .orig.tar.gz could be transported via the git repo as git tags.
+Doing this is made more complicated by the possibility of a `3.0
+(quilt)' package with multiple .orig tarballs.
+
+The error messages are often unhelpfully terse and tend to refer to
+line numbers in dgit.
+
+The option parser requires values to be cuddled to the option name.
+
+dgit assumes knowledge of the archive layout. There appears to be no
+sane way to find the path in the archive pool of the .dsc for a
+particular suite. I'm assured that the archive layout is a
+`well known algorithm' by now.
+
+--dry-run often does not work with fetch, even though this is a
+logically plausible request. (It fails, instead.)