summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit14
2 files changed, 16 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6bc6173..2efcc9c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -24,6 +24,8 @@ dgit (5.2~) unstable; urgency=medium
* Provide `update-vcs-git' subcommand, for creating and adjusting the
vcs-git remote url. Useful for transition from alioth to salsa.
Closes:#902006.
+ * Print a warning to stderr on `dgit fetch sid', if your vcs-git
+ remote url disagrees with what's in sid's .dsc.
test suite:
* Use nproc(1) rather than Sys::CPU. This is more portable and does not
diff --git a/dgit b/dgit
index 48fd4f4..2365bfc 100755
--- a/dgit
+++ b/dgit
@@ -3722,6 +3722,20 @@ sub fetch () {
git_fetch_us();
}
fetch_from_archive() or no_such_package();
+
+ my $vcsgiturl = $dsc && $dsc->{'Vcs-Git'};
+ if (length $vcsgiturl and
+ (grep { $csuite eq $_ }
+ split /\;/,
+ cfg 'dgit.vcs-git.suites')) {
+ my $current = cfg 'remote.vcs-git.url', 'RETURN-UNDEF';
+ if (defined $current && $current ne $vcsgiturl) {
+ print STDERR <<END;
+FYI: Vcs-Git in $csuite has different url to your vcs-git remote.
+ Your vcs-git remote url may be out of date. Use dgit update-vcs-git ?
+END
+ }
+ }
printdone "fetched into ".lrref();
}