summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 68ec24e..da73430 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ dgit (5.2~) unstable; urgency=medium
* dgit(1): Mention under `dgit build' that it uses the network.
dgit:
+ * When all Debian changes vanish with single-debian-patch,
+ do not fail to commit the patch queue removal. Closes:#877036.
* When build fails because the network is offline, mention
that this is because --since-version was not specified.
Closes:#883340.
diff --git a/dgit b/dgit
index 9084eaf..1f065dd 100755
--- a/dgit
+++ b/dgit
@@ -3760,7 +3760,7 @@ sub commit_quilty_patch () {
my %adds;
foreach my $l (split /\n/, $output) {
next unless $l =~ m/\S/;
- if ($l =~ m{^(?:\?\?| M) (.pc|debian/patches)}) {
+ if ($l =~ m{^(?:\?\?| [MADRC]) (.pc|debian/patches)}) {
$adds{$1}++;
}
}