summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit5
-rw-r--r--dgit.14
3 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8695a5f..051b1fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -30,6 +30,7 @@ dgit (0.22~experimental1) experimental; urgency=low
* Provide t-archive-process-incoming and t-archive-query subroutines for
regression test scripts to use.
* Print better message for unknown operations.
+ * Provide `dgit clean'. Closes:#736527.
Major new feature, currently stalled awaiting server infrastructure:
* dgit-repos-server: New program for receiving signed-tag-based
diff --git a/dgit b/dgit
index 2852e13..5f1ef2e 100755
--- a/dgit
+++ b/dgit
@@ -1948,6 +1948,11 @@ sub clean_tree () {
}
}
+sub cmd_clean () {
+ badusage "clean takes no additional arguments" if @ARGV;
+ clean_tree();
+}
+
sub build_prep () {
badusage "-p is not allowed when building" if defined $package;
check_not_dirty();
diff --git a/dgit.1 b/dgit.1
index 1a6945a..5a00dd7 100644
--- a/dgit.1
+++ b/dgit.1
@@ -106,6 +106,10 @@ and
Tagging, signing and actually uploading should be left to dgit push.
.TP
+.B dgit clean
+Cleans the current working tree (according to the --clean= option in
+force).
+.TP
.B dgit help
Print a usage summary.
.TP