summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xtests/tests/overwrite-chkclog11
2 files changed, 14 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d5bef7b..6d9f233 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ dgit (3.9~) unstable; urgency=medium
is not UNRELEASED. This could easily happen if this release was being
made from a git branch which predates the previous package upload.
+ Test suite:
+ * overwrite-chkclog: test UNRELEASED handling.
+
--
dgit (3.8) unstable; urgency=medium
diff --git a/tests/tests/overwrite-chkclog b/tests/tests/overwrite-chkclog
index 3544390..fee2181 100755
--- a/tests/tests/overwrite-chkclog
+++ b/tests/tests/overwrite-chkclog
@@ -23,6 +23,17 @@ git merge dgit/dgit/stable
git checkout master which
EDITOR=: git commit
+perl -i~ -pe 's/^(\w+ \(\S+\)) stable/$1 UNRELEASED/ if $.>1' debian/changelog
+git add debian/changelog
+git commit -m 'UNRELEASED changelog'
+
+t-dgit -wgf build
+
+t-expect-fail E:'Distribution.*is UNRELEASED' \
+t-dgit push --overwrite stable
+
+git revert --no-edit 'HEAD^{/UNRELEASED changelog}'
+
t-dgit -wgf build
perl -i~ -pe 's/^(\w+ \(\S+)(\) stable)/$1+X$2/ if $.>1' debian/changelog