summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f25c5d4..91bb617 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ dgit (3.11~) unstable; urgency=medium
tree. Closes:#865863.
* dgit: rpush: Honour local git config from build host working
tree.
+ * dgit: tolerate compressor terminating with SIGPIPE.
+ Closes:#857694.
* infrastructure: Cope with new git-receive-pack which has
quarantine feature: ie, work around #867702.
* test suite: Cope with git restricting ext:: protocols.
diff --git a/dgit b/dgit
index 6f98813..edb2428 100755
--- a/dgit
+++ b/dgit
@@ -2208,7 +2208,7 @@ sub generate_commits_from_dsc () {
!$? or failedcmd @tarcmd;
close $input or
- (@compr_cmd ? failedcmd @compr_cmd
+ (@compr_cmd ? ($?==SIGPIPE || failedcmd @compr_cmd)
: die $!);
# finally, we have the results in "tarball", but maybe
# with the wrong permissions