summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit1
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 91dd7c4..a340413 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ dgit (4.5~) unstable; urgency=medium
Bugfixes:
* When checking that the tree is clean, check the git index too.
+ * In quilt_fixup_multipatch, work around git checkout paths
+ not deleting files. (Hypothetical bug AFAIAA.)
Minor fixes:
* "confess" when we die due to a warning, rather than symply dieing.
diff --git a/dgit b/dgit
index 17e4fad..49350ee 100755
--- a/dgit
+++ b/dgit
@@ -5701,6 +5701,7 @@ sub quilt_fixup_multipatch ($$$) {
rmtree '.pc';
+ rmtree 'debian'; # git checkout commitish paths does not delete!
runcmd @git, qw(checkout -f), $headref, qw(-- debian);
my $unapplied=git_add_write_tree();
printdebug "fake orig tree object $unapplied\n";