summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xtests/tstunt/dpkg-parsechangelog2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2a49514..c3e0a99 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -30,6 +30,7 @@ dgit (1.1) unstable; urgency=low
check getppid.
* Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch
(using setup_sigwarn).
+ * Make warnings fatal in tstunt/dpkg-parsechangelog (directly).
--
diff --git a/tests/tstunt/dpkg-parsechangelog b/tests/tstunt/dpkg-parsechangelog
index c45b124..f1e75a8 100755
--- a/tests/tstunt/dpkg-parsechangelog
+++ b/tests/tstunt/dpkg-parsechangelog
@@ -14,6 +14,8 @@
# sys 0m0.012s
# $
+$SIG{__WARN__} = sub { die $_[0]; }; # no use of system, so we avoid #793471
+
my $infile = "debian/changelog";
if (@ARGV && $ARGV[0] =~ s/^-l//) {