summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 75515ee..c0c45a1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ dgit (2.5~) unstable; urgency=medium
and improve performance by amortising gnupg migration cost.
* Switch to new archive/ tag format by default, even in
non-split-brain mode.
+ * Do not crash in split brain quilt modes when the two brains are
+ actually identical. Closes:#841770.
--
diff --git a/dgit b/dgit
index 6cdf8d2..5ee61ef 100755
--- a/dgit
+++ b/dgit
@@ -3909,7 +3909,7 @@ Commit patch to update .gitignore
END
}
- my $dgitview = git_rev_parse 'refs/heads/dgit-view';
+ my $dgitview = git_rev_parse 'HEAD';
changedir '../../../..';
# When we no longer need to support squeeze, use --create-reflog