summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit5
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 604d66d..1ab75e1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,9 @@ dgit (1.4~~) UNRELEASED; urgency=low
* In dgit(7), discuss binaries and documentation present in upstream but
removed by rules clean.
* Detect and reject git trees containing debian/source/local-options.
+ * In --dry-run mode, _do_ actually run dpkg-source --commit so that we
+ actually do construct the quilt fixup commit; instead, honour
+ --dry-run by avoiding pulling it back to your HEAD.
--
diff --git a/dgit b/dgit
index d6f37ff..ce858ab 100755
--- a/dgit
+++ b/dgit
@@ -2493,7 +2493,7 @@ END
local $ENV{'EDITOR'} = cmdoutput qw(realpath --), $0;
local $ENV{'VISUAL'} = $ENV{'EDITOR'};
local $ENV{$fakeeditorenv} = cmdoutput qw(realpath --), $descfn;
- runcmd_ordryrun_local @dpkgsource, qw(--commit .), $patchname;
+ runcmd @dpkgsource, qw(--commit .), $patchname;
}
}
@@ -2874,7 +2874,8 @@ END
}
changedir '../../../..';
- runcmd @git, qw(pull --ff-only -q .git/dgit/unpack/work master);
+ runcmd_ordryrun_local
+ @git, qw(pull --ff-only -q .git/dgit/unpack/work master);
}
sub quilt_fixup_editor () {