summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog14
-rwxr-xr-xdgit1
-rw-r--r--dgit.111
-rwxr-xr-xusing-these8
4 files changed, 34 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5478618..5978c66 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+dgit (4.1~) experimental; urgency=medium
+
+ Internal changes:
+ * using-these: New script to help with ad-hoc-testing.
+
+ --
+
+dgit (4.0) experimental; urgency=low
+
+ * dgit: --deliberately-not-fast-forward works properly in
+ split view quilt modes (suppressing the pseudomerge).
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 12 Feb 2017 22:22:31 +0000
+
dgit (3.12) unstable; urgency=high
Important bugfixes to dgit:
diff --git a/dgit b/dgit
index 42647ce..9c7ec73 100755
--- a/dgit
+++ b/dgit
@@ -3913,6 +3913,7 @@ sub splitbrain_pseudomerge ($$$$) {
#
return $dgitview unless defined $archive_hash;
+ return $dgitview if deliberately_not_fast_forward();
printdebug "splitbrain_pseudomerge...\n";
diff --git a/dgit.1 b/dgit.1
index e5b4bb0..2233d95 100644
--- a/dgit.1
+++ b/dgit.1
@@ -554,6 +554,17 @@ Declare that you are deliberately rewinding history. When pushing to
Debian, use this when you are making a renewed upload of an entirely
new source package whose previous version was not accepted for release
from NEW because of problems with copyright or redistributibility.
+
+In split view quilt modes,
+this also prevents the construction by dgit of a pseudomerge
+to make the dgit view fast forwarding.
+Normally only one of
+--overwrite (which creates a suitable pseudomerge)
+and
+--deliberately-not-fast-forward
+(which suppresses the pseudomerge and the fast forward checks)
+should be needed;
+--overwrite is usually better.
.TP
.BR --deliberately-include-questionable-history
Declare that you are deliberately including, in the git history of
diff --git a/using-these b/using-these
new file mode 100755
index 0000000..0bcb4b1
--- /dev/null
+++ b/using-these
@@ -0,0 +1,8 @@
+#!/bin/bash
+set -e
+d="${0%/*}"
+PERLLIB=$d${PERLLIB:+:}${PERLLIB}
+export PERLLIB
+PATH=$d:$d/infra${PATH:+:}${PATH}
+export PATH
+exec "$@"