summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 19a1a9f..ed7fd90 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -24,6 +24,7 @@ dgit (2.9~) unstable; urgency=low
Closes:#842608.
* Cope when cloning suite which doesn't receive uploads,
like testing. Closes:#842621.
+ * Properly fetch all archive dgit view tags, as we intended.
--
diff --git a/dgit b/dgit
index b17ed21..f494bb4 100755
--- a/dgit
+++ b/dgit
@@ -2337,7 +2337,7 @@ END
# OK, now %want is exactly what we want for refs in @specs
my @fspecs = map {
- return () if !m/\*$/ && !exists $wantr{"refs/$_"};
+ !m/\*$/ && !exists $wantr{"refs/$_"} ? () :
"+refs/$_:".lrfetchrefs."/$_";
} @specs;