summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit23
2 files changed, 16 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 5842873..30db5c9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,6 +22,8 @@ dgit (1.5~~) unstable; urgency=medium
Instead, insist on a single one.
* dgit sbuild no longer deletes extranious .changes files; instead
we rely on --rm-old-changes, or failing that, fail early.
+ * When doing quilt linearisation, treat upstream .gitignores not
+ in the toplevel the same way we treat ones in the toplevel.
Infrastructure:
* Better error handling in dgit-repos-policy-debian.
diff --git a/dgit b/dgit
index c64f0fe..0c8183d 100755
--- a/dgit
+++ b/dgit
@@ -2511,17 +2511,22 @@ END
}
sub quiltify_trees_differ ($$;$) {
- my ($x,$y,$ignoregitignore) = @_;
- # returns 1 iff the two tree objects differ other than in debian/
+ my ($x,$y,$finegrained) = @_;
+ # returns true iff the two tree objects differ other than in debian/
+ # returns bitmas 01 - differ in upstream files except .gitignore
+ # 02 - differ in .gitignore
local $/=undef;
- my @cmd = (@git, qw(diff-tree --name-only -z), $x, $y);
+ my @cmd = (@git, qw(diff-tree --name-only -z));
+ push @cmd, qw(-r) if $finegrained;
+ push @cmd, $x, $y;
my $diffs= cmdoutput @cmd;
+ my $r = 0;
foreach my $f (split /\0/, $diffs) {
- next if $f eq 'debian';
- next if $f eq '.gitignore' && $ignoregitignore;
- return 1;
+ next if $f =~ m#^debian(?:/.*)?$#s;
+ $r |= ($f =~ m#^(?:.*/)?.gitignore$#s) ? 02 : 01;
}
- return 0;
+ printdebug "quiltify_trees_differ $x $y => $r\n";
+ return $r;
}
sub quiltify_tree_sentinelfiles ($) {
@@ -2536,8 +2541,8 @@ sub quiltify_tree_sentinelfiles ($) {
sub quilt_could_gbp ($$$) {
my ($userhead,$unapplied,$applied) = @_;
return
- !quiltify_trees_differ($userhead,$unapplied,1) &&
- quiltify_trees_differ($userhead,$applied,1);
+ !(quiltify_trees_differ($userhead,$unapplied,1) & 01) &&
+ (quiltify_trees_differ($userhead,$applied,1) & 01);
}
sub quiltify ($$$$) {