summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit5
2 files changed, 2 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 0a499cb..63d9a8a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
dgit (0.16) unstable; urgency=low
+ * Format `(3.0) quilt' fixup does not mind extraneous other files
+ in the build tree (e.g., build products and logs). Closes: #727053.
* Set autoflush on stdout, to get better ordering of debugging
etc. output when stdout is redirected.
* New --damp-run mode, for more convenient and fuller testing etc.
diff --git a/dgit b/dgit
index 3c13d79..ba5f1ba 100755
--- a/dgit
+++ b/dgit
@@ -871,17 +871,12 @@ sub check_not_dirty () {
sub commit_quilty_patch () {
my $output = cmdoutput @git, qw(status --porcelain);
my %adds;
- my $bad=0;
foreach my $l (split /\n/, $output) {
next unless $l =~ m/\S/;
if ($l =~ m{^(?:\?\?| M) (.pc|debian/patches)}) {
$adds{$1}++;
- } else {
- print STDERR "git status: $l\n";
- $bad++;
}
}
- fail "unexpected output from git status (is tree clean?)" if $bad;
if (!%adds) {
print "nothing quilty to commit, ok.\n";
return;