summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--tests/lib4
-rw-r--r--tests/lib-mirror2
3 files changed, 9 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8edf527..05ab9d0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ dgit (3.2~) unstable; urgency=medium
bug seem to be limited to duplicated error messages but I have not
done a thorough analysis. Closes:#850052.
+ Test suite:
+ * infra: mirroring and policy hooks: Improve some debugging output.
+
--
dgit (3.1) unstable; urgency=medium
diff --git a/tests/lib b/tests/lib
index 7023dbf..2607ca2 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1024,7 +1024,9 @@ t-dsd () {
}
t-policy-admin () {
+ : '(((((((((((((((((((((((((((((((((((((((('
${DGIT_INFRA_PFX}dgit-repos-admin-debian --repos $tmp/git "$@"
+ : '))))))))))))))))))))))))))))))))))))))))'
}
t-policy-nonexist () {
@@ -1056,8 +1058,10 @@ t-debpolicy () {
}
t-policy-periodic () {
+ : '(((((((((((((((((((((((((((((((((((((((('
${DGIT_REPOS_SERVER_TEST-dgit-repos-server} \
test-dummy $drs_dispatch '' --cron
+ : '))))))))))))))))))))))))))))))))))))))))'
}
t-restrict () {
diff --git a/tests/lib-mirror b/tests/lib-mirror
index 8aa751a..25f0f90 100644
--- a/tests/lib-mirror
+++ b/tests/lib-mirror
@@ -22,7 +22,9 @@ t-mirror-set () {
}
t-mirror-hook () {
+ : '(((((((((((((((((((((((((((((((((((((((('
"$mirror_hook" "$drs_dispatch" "$@"
+ : '))))))))))))))))))))))))))))))))))))))))'
}
t-check-mirrored () {