summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdgit2
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 39cbff1..badf374 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (0.13) unstable; urgency=low
+
+ * Remove DGET_UNPACK from the environment in case the user has set it.
+
+ --
+
dgit (0.12) unstable; urgency=low
* Cope with packages with epoch. Closes: #720897.
diff --git a/dgit b/dgit
index 9602b98..e1b0797 100755
--- a/dgit
+++ b/dgit
@@ -1247,6 +1247,8 @@ if ($ENV{$fakeeditorenv}) {
quilt_fixup_editor();
}
+delete $ENV{'DGET_UNPACK'};
+
parseopts();
print STDERR "DRY RUN ONLY\n" if $dryrun;
if (!@ARGV) {