summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--tests/lib-orig-include-exclude3
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 30c0bf3..efb9c5b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ dgit (2.17~) unstable; urgency=medium
* Internal improvements.
* badcommit-rewrite: Fix operation using installed version of fixup.
* Arrange to pass --debug-quick-random to gpg-agent.
+ * Strip block count out of find -ls output - it is unstable!
--
diff --git a/tests/lib-orig-include-exclude b/tests/lib-orig-include-exclude
index c3b7b43..104cf0b 100644
--- a/tests/lib-orig-include-exclude
+++ b/tests/lib-orig-include-exclude
@@ -39,7 +39,8 @@ grep orig ../${p}_${v}_*.changes
test-push-2
origs_findls () {
- find $tmp/mirror -name '*orig*' -ls
+ find $tmp/mirror -name '*orig*' -ls \
+ | perl -pe 's/^(\s*\d+\s+\d+\s+\S+\s)\s*\d+(\s)/$1$2/'
}
# check that dgit stripped out the orig update